ยซ Up

tactician-stdlib 8.13.dev Not compatible ๐Ÿ‘ผ

๐Ÿ“… (2022-05-24 01:37:32 UTC)

Context

# Packages matching: installed
# Name              # Installed # Synopsis
base-bigarray       base
base-threads        base
base-unix           base
conf-findutils      1           Virtual package relying on findutils
conf-gmp            4           Virtual package relying on a GMP lib system installation
coq                 dev         Formal proof management system
dune                3.1.1       Fast, portable, and opinionated build system
ocaml               4.10.2      The OCaml compiler (virtual package)
ocaml-base-compiler 4.10.2      Official release 4.10.2
ocaml-config        1           OCaml Switch Configuration
ocamlfind           1.9.3       A library manager for OCaml
zarith              1.12        Implements arithmetic and logical operations over arbitrary-precision integers
# opam file:
opam-version: "2.0"
name: "coq-tactician-stdlib"
synopsis: "Recompiles Coq's standard libary with Tactician's instrumentation loaded"
description: """
  *** WARNING *** This package will overwrite Coq's standard library files.
  This package recompiles Coq's standard library with Tactician's (`coq-tactician`)
  instrumentation loaded such that Tactician can learn from the library. When you
  install this package, the current `.vo` files of the standard library are backed
  in the folder `user-contrib/Tactician/stdlib-backup`. The new `.vo` files are
  equivalent to the originals, except that they also contain Tactician's tactic
  databases. After installation of this package, all other Coq developments that
  are installed will also need to be recompiled. The 'tactician recompile' command
  line utility can help with this.
  Upon removal of this package, the original files will be placed back.
"""
homepage: "https://coq-tactician.github.io"
dev-repo: "git+https://github.com/coq-tactician/coq-tactician-stdlib"
bug-reports: "https://github.com/coq-tactician/coq-tactician-stdlib/issues"
maintainer: "Lasse Blaauwbroek <lasse@blaauwbroek.eu>"
authors: "Lasse Blaauwbroek <lasse@blaauwbroek.eu"
messages: [
  "*** WARNING ***"
  "This package will overwrite Coq's standard library files."
  "A backup of the original files will be placed under Coq's"
  "library directory at user-contrib/tactician-stdlib-backup/"
  "and they will be restored when you remove this package."
  "After installation of this package, all other Coq packages"
  "also need to be recompiled. Running the 'tactician recompile'"
  "command-line utility will help with this process."
]
post-messages: ["
--- The standard library was successfully recompiled ---
In order to finish the process, you should run
tactician recompile
" {success}]
depends: [
  "coq" {>= "8.13" & < "8.14~"}
  "coq-tactician"
]
build: [
  [make "-j%{jobs}%"]
]
install: [
  [make "install"]
]
remove: [
  [make "restore"]
]
url {
  src: "git+https://github.com/coq-tactician/coq-tactician-stdlib.git#coq8.13"
}
tags: [
  "keyword:tactic-learning"
  "keyword:machine-learning"
  "keyword:automation"
  "keyword:proof-synthesis"
  "category:Miscellaneous/Coq Extensions"
  "logpath:Tactician"
]

Lint

Command
true
Return code
0

Dry install ๐Ÿœ๏ธ

Dry install with the current Coq version:

Command
opam install -y --show-action coq-tactician-stdlib.8.13.dev coq.dev
Return code
5120
Output
[NOTE] Package coq is already installed (current version is dev).
The following dependencies couldn't be met:
  - coq-tactician-stdlib -> coq < 8.14~ -> ocaml < 4.10
      base of this switch (use `--unlock-base' to force)
Your request can't be satisfied:
  - No available version of coq satisfies the constraints
No solution found, exiting

Dry install without Coq/switch base, to test if the problem was incompatibility with the current Coq/OCaml version:

Command
opam remove -y coq; opam install -y --show-action --unlock-base coq-tactician-stdlib.8.13.dev
Return code
0

Install dependencies

Command
true
Return code
0
Duration
0 s

Install ๐Ÿš€

Command
true
Return code
0
Duration
0 s

Installation size

No files were installed.

Uninstall ๐Ÿงน

Command
true
Return code
0
Missing removes
none
Wrong removes
none