ยซ Up

dpdgraph 0.6.2 Not compatible ๐Ÿ‘ผ

๐Ÿ“… (2022-05-14 08:21:45 UTC)

Context

# Packages matching: installed
# Name                # Installed # Synopsis
base-bigarray         base
base-threads          base
base-unix             base
conf-findutils        1           Virtual package relying on findutils
conf-gmp              4           Virtual package relying on a GMP lib system installation
coq                   dev         Formal proof management system
dune                  3.1.1       Fast, portable, and opinionated build system
ocaml                 4.12.1      The OCaml compiler (virtual package)
ocaml-base-compiler   4.12.1      Official release 4.12.1
ocaml-config          2           OCaml Switch Configuration
ocaml-options-vanilla 1           Ensure that OCaml is compiled with no special options enabled
ocamlfind             1.9.3       A library manager for OCaml
zarith                1.12        Implements arithmetic and logical operations over arbitrary-precision integers
# opam file:
opam-version: "2.0"
maintainer: "yves.bertot@inria.fr"
license: "LGPL 2.1"
homepage: "https://github.com/karmaki/coq-dpdgraph"
build: [
  ["./configure"]
  ["echo" "%{jobs}%" "jobs for the linter"]
  [make]
 ]
bug-reports: "https://github.com/karmaki/coq-dpdgraph/issues"
dev-repo: "git+https://github.com/karmaki/coq-dpdgraph.git"
install: [
  [make "install" "BINDIR=%{bin}%"]
]
remove: [
  ["rm" "%{bin}%/dpd2dot" "%{bin}%/dpdusage"]
  ["rm" "-R" "%{lib}%/coq/user-contrib/dpdgraph"]
]
depends: [
  "ocaml" {< "4.08.0"}
  "coq" {>= "8.7" & < "8.8~"}
  "ocamlgraph"
]
authors: [ "Anne Pacalet" "Yves Bertot"]
synopsis: "Compute dependencies between Coq objects (definitions, theorems) and produce graphs"
flags: light-uninstall
url {
  src:
    "https://github.com/Karmaki/coq-dpdgraph/releases/download/v0.6.2/coq-dpdgraph-0.6.2.tgz"
  checksum: "md5=495ae6444af63129b5ec0001855228d4"
}

Lint

Command
true
Return code
0

Dry install ๐Ÿœ๏ธ

Dry install with the current Coq version:

Command
opam install -y --show-action coq-dpdgraph.0.6.2 coq.dev
Return code
5120
Output
[NOTE] Package coq is already installed (current version is dev).
The following dependencies couldn't be met:
  - coq-dpdgraph -> ocaml < 4.08.0
      base of this switch (use `--unlock-base' to force)
No solution found, exiting

Dry install without Coq/switch base, to test if the problem was incompatibility with the current Coq/OCaml version:

Command
opam remove -y coq; opam install -y --show-action --unlock-base coq-dpdgraph.0.6.2
Return code
0

Install dependencies

Command
true
Return code
0
Duration
0 s

Install ๐Ÿš€

Command
true
Return code
0
Duration
0 s

Installation size

No files were installed.

Uninstall ๐Ÿงน

Command
true
Return code
0
Missing removes
none
Wrong removes
none