ยซ Up

hammer 1.0.3 Not compatible ๐Ÿ‘ผ

๐Ÿ“… (2022-05-14 08:21:45 UTC)

Context

# Packages matching: installed
# Name                # Installed # Synopsis
base-bigarray         base
base-threads          base
base-unix             base
conf-findutils        1           Virtual package relying on findutils
conf-gmp              4           Virtual package relying on a GMP lib system installation
coq                   dev         Formal proof management system
dune                  3.1.1       Fast, portable, and opinionated build system
ocaml                 4.12.1      The OCaml compiler (virtual package)
ocaml-base-compiler   4.12.1      Official release 4.12.1
ocaml-config          2           OCaml Switch Configuration
ocaml-options-vanilla 1           Ensure that OCaml is compiled with no special options enabled
ocamlfind             1.9.3       A library manager for OCaml
zarith                1.12        Implements arithmetic and logical operations over arbitrary-precision integers
# opam file:
opam-version: "2.0"
maintainer: "Julien Narboux <julien@narboux.fr>"
homepage: "http://cl-informatik.uibk.ac.at/cek/coqhammer/"
bug-reports: "mailto://lukaszcz@mimuw.edu.pl"
authors: ["ล. Czajka"
 	  "Cezary Kaliszyk"]
license: "LGPL 2.1"
build: [
  ["sed" "-i" "s|usr\\/local|%{prefix}%|g" "_CoqProject"]
  ["coq_makefile" "-f" "_CoqProject" "-o" "Makefile"]
  [make]
]
install: [
  [make "install"]
]
remove: [
	["rm" "-R" "%{lib}%/coq/user-contrib/Hammer"]
	["rm" "%{prefix}%/bin/predict"]
]
depends: [
  "ocaml"
  "conf-g++" {build}
  "coq" {(>= "8.6" & < "8.7~")}
]
tags: [ "keyword:automation"
	"category:Miscellaneous/Coq Extensions"
	"date:2017-09-30"  ]
synopsis: "Automation for Dependent Type Theory"
flags: light-uninstall
url {
  src:
    "http://cl-informatik.uibk.ac.at/cek/coqhammer/coqhammer-1.0.3-coq8.6.tar.gz"
  checksum: "md5=4d0fb044c9ddecac60b6aea7310a2379"
}

Lint

Command
true
Return code
0

Dry install ๐Ÿœ๏ธ

Dry install with the current Coq version:

Command
opam install -y --show-action coq-hammer.1.0.3 coq.dev
Return code
5120
Output
[NOTE] Package coq is already installed (current version is dev).
The following dependencies couldn't be met:
  - coq-hammer -> coq < 8.7~ -> ocaml < 4.06.0
      base of this switch (use `--unlock-base' to force)
Your request can't be satisfied:
  - No available version of coq satisfies the constraints
No solution found, exiting

Dry install without Coq/switch base, to test if the problem was incompatibility with the current Coq/OCaml version:

Command
opam remove -y coq; opam install -y --show-action --unlock-base coq-hammer.1.0.3
Return code
0

Install dependencies

Command
true
Return code
0
Duration
0 s

Install ๐Ÿš€

Command
true
Return code
0
Duration
0 s

Installation size

No files were installed.

Uninstall ๐Ÿงน

Command
true
Return code
0
Missing removes
none
Wrong removes
none