« Up

jsast 1.0.9 Not compatible 👼

📅 (2022-05-14 08:21:45 UTC)

Context

# Packages matching: installed
# Name                # Installed # Synopsis
base-bigarray         base
base-threads          base
base-unix             base
conf-findutils        1           Virtual package relying on findutils
conf-gmp              4           Virtual package relying on a GMP lib system installation
coq                   dev         Formal proof management system
dune                  3.1.1       Fast, portable, and opinionated build system
ocaml                 4.12.1      The OCaml compiler (virtual package)
ocaml-base-compiler   4.12.1      Official release 4.12.1
ocaml-config          2           OCaml Switch Configuration
ocaml-options-vanilla 1           Ensure that OCaml is compiled with no special options enabled
ocamlfind             1.9.3       A library manager for OCaml
zarith                1.12        Implements arithmetic and logical operations over arbitrary-precision integers
# opam file:
opam-version: "2.0"
maintainer: "Jerome Simeon <jeromesimeon@me.com>"
homepage: "https://github.com/querycert/jsast"
bug-reports: "https://github.com/querycert/jsast/issues"
dev-repo: "git+https://github.com/querycert/jsast/tree/JsAst"
license: "BSD-2-Clause"
build: [
  [make "-j%{jobs}%"]
]
install: [
  [make "install"]
]
depends: [
  "ocaml"
  "coq" {>= "8.7.2" & < "8.9~"}
  "coq-flocq" {>= "2.6.1" & < "3.0~"}
]
tags: [ "keyword:javascript" "keyword:compiler" "date:2019-11-25" "logpath:JsAst" ]
authors: [
    "Martin Bodin <>"
    "Arthur Charguéraud <>"
    "Daniele Filaretti <>"
    "Philippa Gardner <>"
    "Sergio Maffeis <>"
    "Daiva Naudziuniene <>"
    "Alan Schmitt <>"
    "Gareth Smith <>"
    "Josh Auerbach <>"
    "Martin Hirzel <>"
    "Louis Mandel <>"
    "Avi Shinnar <>"
    "Jerome Simeon <>"
]
synopsis: "A minimal JavaScript syntax tree carved out of the JsCert project"
description: """
A minimal JavaScript syntax tree carved out of the JsCert project, with additional support for let bindings.
"""
url {
  src: "https://github.com/querycert/jsast/archive/v1.0.9.tar.gz"
  checksum: "md5=5006334c6e311299e13e30b85f2bf54b"
}

Lint

Command
true
Return code
0

Dry install 🏜️

Dry install with the current Coq version:

Command
opam install -y --show-action coq-jsast.1.0.9 coq.dev
Return code
5120
Output
[NOTE] Package coq is already installed (current version is dev).
The following dependencies couldn't be met:
  - coq-jsast -> coq < 8.9~ -> ocaml < 4.10
      base of this switch (use `--unlock-base' to force)
Your request can't be satisfied:
  - No available version of coq satisfies the constraints
No solution found, exiting

Dry install without Coq/switch base, to test if the problem was incompatibility with the current Coq/OCaml version:

Command
opam remove -y coq; opam install -y --show-action --unlock-base coq-jsast.1.0.9
Return code
0

Install dependencies

Command
true
Return code
0
Duration
0 s

Install 🚀

Command
true
Return code
0
Duration
0 s

Installation size

No files were installed.

Uninstall 🧹

Command
true
Return code
0
Missing removes
none
Wrong removes
none