ยซ Up

legacy-ring 8.6.0 Not compatible ๐Ÿ‘ผ

๐Ÿ“… (2022-05-14 08:21:45 UTC)

Context

# Packages matching: installed
# Name                # Installed # Synopsis
base-bigarray         base
base-threads          base
base-unix             base
conf-findutils        1           Virtual package relying on findutils
conf-gmp              4           Virtual package relying on a GMP lib system installation
coq                   dev         Formal proof management system
dune                  3.1.1       Fast, portable, and opinionated build system
ocaml                 4.12.1      The OCaml compiler (virtual package)
ocaml-base-compiler   4.12.1      Official release 4.12.1
ocaml-config          2           OCaml Switch Configuration
ocaml-options-vanilla 1           Ensure that OCaml is compiled with no special options enabled
ocamlfind             1.9.3       A library manager for OCaml
zarith                1.12        Implements arithmetic and logical operations over arbitrary-precision integers
# opam file:
opam-version: "2.0"
maintainer: "Hugo.Herbelin@inria.fr"
homepage: "https://github.com/coq-contribs/legacy-ring"
license: "Unknown"
build: [make]
install: [make "install"]
depends: [
  "ocaml"
  "coq" {>= "8.6" & < "8.7~"}
]
tags: [ "date: 1998-5" ]
authors: [ "Patrick Loiseleur" ]
bug-reports: "https://github.com/coq-contribs/legacy-ring/issues"
dev-repo: "git+https://github.com/coq-contribs/legacy-ring.git"
synopsis: "The former implementation of the ring tactic"
description: """
Tactics to decide equality and simplify polynomial
expressions over an arbitrary commutative ring. This generalizes a
previous tactics by Samuel Boutin."""
url {
  src: "https://github.com/coq-contribs/legacy-ring/archive/v8.6.0.tar.gz"
  checksum: "md5=6c54ffd5bf1e4f816c5d404ca87d079b"
}

Lint

Command
true
Return code
0

Dry install ๐Ÿœ๏ธ

Dry install with the current Coq version:

Command
opam install -y --show-action coq-legacy-ring.8.6.0 coq.dev
Return code
5120
Output
[NOTE] Package coq is already installed (current version is dev).
The following dependencies couldn't be met:
  - coq-legacy-ring -> coq < 8.7~ -> ocaml < 4.06.0
      base of this switch (use `--unlock-base' to force)
Your request can't be satisfied:
  - No available version of coq satisfies the constraints
No solution found, exiting

Dry install without Coq/switch base, to test if the problem was incompatibility with the current Coq/OCaml version:

Command
opam remove -y coq; opam install -y --show-action --unlock-base coq-legacy-ring.8.6.0
Return code
0

Install dependencies

Command
true
Return code
0
Duration
0 s

Install ๐Ÿš€

Command
true
Return code
0
Duration
0 s

Installation size

No files were installed.

Uninstall ๐Ÿงน

Command
true
Return code
0
Missing removes
none
Wrong removes
none