ยซ Up

tactician 1.0~beta1+8.11 Not compatible ๐Ÿ‘ผ

๐Ÿ“… (2022-05-14 08:21:45 UTC)

Context

# Packages matching: installed
# Name                # Installed # Synopsis
base-bigarray         base
base-threads          base
base-unix             base
conf-findutils        1           Virtual package relying on findutils
conf-gmp              4           Virtual package relying on a GMP lib system installation
coq                   dev         Formal proof management system
dune                  3.1.1       Fast, portable, and opinionated build system
ocaml                 4.12.1      The OCaml compiler (virtual package)
ocaml-base-compiler   4.12.1      Official release 4.12.1
ocaml-config          2           OCaml Switch Configuration
ocaml-options-vanilla 1           Ensure that OCaml is compiled with no special options enabled
ocamlfind             1.9.3       A library manager for OCaml
zarith                1.12        Implements arithmetic and logical operations over arbitrary-precision integers
# opam file:
opam-version: "2.0"
name: "coq-tactician"
synopsis: "Tactician: A Seamless, Interactive Tactic Learner and Prover for Coq"
description: """
  Tactician is a tactic learner and prover for the Coq Proof Assistant.
  The system will help users make tactical proof decisions while they retain
  control over the general proof strategy. To this end, Tactician will learn
  from previously written tactic scripts, and either gives the user suggestions
  about the next tactic to be executed or altogether takes over the burden of
  proof synthesis. Tactician's goal is to provide the user with a seamless,
  interactive, and intuitive experience together with strong, adaptive proof
  automation.
"""
homepage: "https://coq-tactician.github.io"
dev-repo: "git+https://github.com/coq-tactician/coq-tactician"
bug-reports: "https://github.com/coq-tactician/coq-tactician/issues"
maintainer: "Lasse Blaauwbroek <lasse@blaauwbroek.eu>"
authors: "Lasse Blaauwbroek <lasse@blaauwbroek.eu"
depends: [
  "ocaml" {>= "4.08"}
  "dune" {>= "2.5"}
  "opam-client" {>= "2.1.0~beta2"}
  "cmdliner"
  "coq" {>= "8.11" & < "8.12~"}
  "coq-tactician-dummy"
]
depexts: ["git"]
build: [
  ["dune" "build" "--release" "-j" jobs]
]
post-messages: ["
--- Tactician was successfully installed ---
In order to enable Tactician, you should run
tactician enable
" {success}]
url {
  src: "https://github.com/coq-tactician/coq-tactician/archive/1.0-beta1-8.11.tar.gz"
}
tags: [
  "keyword:tactic-learning"
  "keyword:machine-learning"
  "keyword:automation"
  "keyword:proof-synthesis"
  "category:Miscellaneous/Coq Extensions"
  "logpath:Tactician"
]

Lint

Command
true
Return code
0

Dry install ๐Ÿœ๏ธ

Dry install with the current Coq version:

Command
opam install -y --show-action coq-tactician.1.0~beta1+8.11 coq.dev
Return code
5120
Output
[NOTE] Package coq is already installed (current version is dev).
The following dependencies couldn't be met:
  - coq-tactician -> coq < 8.12~ -> ocaml < 4.12
      base of this switch (use `--unlock-base' to force)
Your request can't be satisfied:
  - No available version of coq satisfies the constraints
No solution found, exiting

Dry install without Coq/switch base, to test if the problem was incompatibility with the current Coq/OCaml version:

Command
opam remove -y coq; opam install -y --show-action --unlock-base coq-tactician.1.0~beta1+8.11
Return code
0

Install dependencies

Command
true
Return code
0
Duration
0 s

Install ๐Ÿš€

Command
true
Return code
0
Duration
0 s

Installation size

No files were installed.

Uninstall ๐Ÿงน

Command
true
Return code
0
Missing removes
none
Wrong removes
none